<!DOCTYPE html>
<html lang="en-US" itemscope itemtype="https://schema.org/BlogPosting">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1, minimum-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<script>!function(){"use strict";for(var t=window.location.search.substring(1).split("&"),e=0;e<t.length;e++){var i="adt_ei",a=t[e];if(0===a.indexOf(i)){var r=a.split(i+"=")[1];localStorage.setItem(i,r),t.splice(e,1),history.replaceState(null,"","?"+t.join("&"));break}}}();
</script><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<style data-no-optimize="1" data-cfasync="false">
	.adthrive-ad {
		margin-top: 10px;
		margin-bottom: 10px;
		text-align: center;
		overflow-x: visible;
		clear: both;
		line-height: 0;
	}
	body.home .adthrive-content, body.archive .adthrive-content, body.search .adthrive-content {
    flex: 0 0 100%;
}</style>
<script data-no-optimize="1" data-cfasync="false">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</script>
<script data-no-optimize="1" data-cfasync="false">
(function(w, d) {
	w.adthrive = w.adthrive || {};
	w.adthrive.cmd = w.adthrive.cmd || [];
	w.adthrive.plugin = 'adthrive-ads-2.3.1';
	w.adthrive.host = 'ads.adthrive.com';
	w.adthrive.integration = 'plugin';

	var commitParam = (w.adthriveCLS && w.adthriveCLS.bucket !== 'prod' && w.adthriveCLS.branch) ? '&commit=' + w.adthriveCLS.branch : '';

	var s = d.createElement('script');
	s.async = true;
	s.referrerpolicy='no-referrer-when-downgrade';
	s.src = 'https://' + w.adthrive.host + '/sites/63050264104c95707c365032/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href) + commitParam + '&cb=' + (Math.floor(Math.random() * 100) + 1) + '';
	var n = d.getElementsByTagName('script')[0];
	n.parentNode.insertBefore(s, n);
})(window, document);
</script>

<title>Conor Benn suspension not guaranteed, Doctor urged to speak</title>
<meta name="description" content="Due to the relinquishing of his British Boxing license, Conor Benn could escape suspension for drug tests, World Boxing News understands." />
<link rel="canonical" href="https://www.worldboxingnews.net/2022/10/29/conor-benn-suspension-doctor-speak/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Conor Benn suspension not guaranteed, Doctor urged to speak" />
<meta property="og:description" content="Founded in 2010, World Boxing News or WBN is dedicated to reporting boxing news and results from around the world featuring the biggest names in the sport. We provide the biggest news stories and opinion articles." />
<meta property="og:url" content="https://www.worldboxingnews.net/2022/10/29/conor-benn-suspension-doctor-speak/" />
<meta property="og:site_name" content="WBN - World Boxing News" />
<meta property="article:publisher" content="https://www.facebook.com/officialworldboxingnews/" />
<meta property="article:author" content="https://www.facebook.com/philjwbn" />
<meta property="article:published_time" content="2022-10-29T10:07:09+00:00" />
<meta property="article:modified_time" content="2022-10-29T10:07:28+00:00" />
<meta property="og:image" content="https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="675" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Phil Jay" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@worldboxingnews" />
<meta name="twitter:site" content="@worldboxingnews" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel='dns-prefetch' href='//static.addtoany.com' />
<link rel="alternate" type="application/rss+xml" title="WBN - World Boxing News &raquo; Feed" href="https://www.worldboxingnews.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="WBN - World Boxing News &raquo; Comments Feed" href="https://www.worldboxingnews.net/comments/feed/" />
<link id='omgf-preload-0' rel='preload' href='https://www.worldboxingnews.net/wp-content/uploads/omgf/omgf-stylesheet-136/khand-normal-latin-ext-700.woff2' as='font' type='font/woff2' crossorigin />
<link id='omgf-preload-1' rel='preload' href='https://www.worldboxingnews.net/wp-content/uploads/omgf/omgf-stylesheet-136/khand-normal-latin-700.woff2' as='font' type='font/woff2' crossorigin />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.worldboxingnews.net/wp-includes/css/dist/block-library/style.min.css?ver=6.0.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='neve-style-css' href='https://www.worldboxingnews.net/wp-content/themes/neve/style-main-new.min.css?ver=3.3.7' type='text/css' media='all' />
<style id='neve-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='neve-blog-pro-css' href='https://www.worldboxingnews.net/wp-content/plugins/neve-pro-addon/includes/modules/blog_pro/assets/style.min.css?ver=2.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css' href='https://www.worldboxingnews.net/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.16' type='text/css' media='all' />
<link rel='stylesheet' id='neve-child-style-css' href='https://www.worldboxingnews.net/wp-content/themes/neve-child-master/style.css?ver=3.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='hfg_module-css' href='https://www.worldboxingnews.net/wp-content/plugins/neve-pro-addon/includes/modules/header_footer_grid/assets/style.min.css?ver=2.4.3' type='text/css' media='all' />
<script type='text/javascript' id='addtoany-core-js-before'>
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
</script>
<script type='text/javascript' async src='https://static.addtoany.com/menu/page.js' id='addtoany-core-js'></script>
<script type='text/javascript' src='https://www.worldboxingnews.net/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.worldboxingnews.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' async src='https://www.worldboxingnews.net/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-jquery-js'></script>

<meta property="og:image" content="https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1.jpg" /><meta property="og:image:secure_url" content="https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1.jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image:alt" content="Conor Benn doctor" /><meta property="og:image:type" content="image/jpeg" /><meta property="og:description" content="Due to the relinquishing of his British Boxing license, Conor Benn could escape suspension for two failed drug tests, World Boxing News understands. The tests, one dating back three months, as father Nigel Benn stated before correcting himself to &quot;three weeks,&quot; were ratified with trace amounts of the same drug. Benn gave up his UK..." /><meta property="og:type" content="article" /><meta property="og:locale" content="en_US" /><meta property="og:site_name" content="WBN - World Boxing News" /><meta property="og:title" content="Conor Benn suspension not guaranteed, Doctor urged to speak" /><meta property="og:url" content="https://www.worldboxingnews.net/2022/10/29/conor-benn-suspension-doctor-speak/" /><meta property="og:updated_time" content="2022-10-29T11:07:28+01:00" />
<meta property="article:tag" content="British Boxing Board of Control" /><meta property="article:tag" content="Conor Benn" /><meta property="article:tag" content="UKAD" /><meta property="article:tag" content="VADA" /><meta property="article:tag" content="WBC" /><meta property="article:published_time" content="2022-10-29T10:07:09+00:00" /><meta property="article:modified_time" content="2022-10-29T10:07:28+00:00" /><meta property="article:section" content="Featured" /><meta property="article:author:first_name" content="Phil" /><meta property="article:author:last_name" content="Jay" /><meta property="article:author:username" content="Phil Jay" />
<meta property="twitter:partner" content="ogwp" /><meta property="twitter:card" content="summary_large_image" /><meta property="twitter:image" content="https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1.jpg" /><meta property="twitter:image:alt" content="Conor Benn doctor" /><meta property="twitter:title" content="Conor Benn suspension not guaranteed, Doctor urged to speak" /><meta property="twitter:description" content="Due to the relinquishing of his British Boxing license, Conor Benn could escape suspension for two failed drug tests, World Boxing News understands. The tests, one dating back three months, as..." /><meta property="twitter:url" content="https://www.worldboxingnews.net/2022/10/29/conor-benn-suspension-doctor-speak/" />
<meta itemprop="image" content="https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1.jpg" /><meta itemprop="name" content="Conor Benn suspension not guaranteed, Doctor urged to speak" /><meta itemprop="headline" content="Conor Benn suspension not guaranteed, Doctor urged to speak" /><meta itemprop="description" content="Due to the relinquishing of his British Boxing license, Conor Benn could escape suspension for two failed drug tests, World Boxing News understands. The tests, one dating back three months, as father Nigel Benn stated before correcting himself to &quot;three weeks,&quot; were ratified with trace amounts of the same drug. Benn gave up his UK..." /><meta itemprop="datePublished" content="2022-10-29" /><meta itemprop="dateModified" content="2022-10-29T10:07:28+00:00" /><meta itemprop="author" content="Phil Jay" />
<meta property="profile:first_name" content="Phil" /><meta property="profile:last_name" content="Jay" /><meta property="profile:username" content="Phil Jay" />

<link rel="https://api.w.org/" href="https://www.worldboxingnews.net/wp-json/" /><link rel="alternate" type="application/json" href="https://www.worldboxingnews.net/wp-json/wp/v2/posts/99945" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.worldboxingnews.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.worldboxingnews.net/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.3" />
<link rel='shortlink' href='https://www.worldboxingnews.net/?p=99945' />
<meta name="generator" content="Site Kit by Google 1.86.0" /><link rel="dns-prefetch" href="https://ads.adthrive.com/"><link rel="preconnect" href="https://ads.adthrive.com/"><link rel="preconnect" href="https://ads.adthrive.com/" crossorigin><link rel="amphtml" href="https://www.worldboxingnews.net/2022/10/29/conor-benn-suspension-doctor-speak/?amp=1"><link rel="icon" href="https://www.worldboxingnews.net/wp-content/uploads/2022/09/cropped-WBN-squate-stripes-Copy-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.worldboxingnews.net/wp-content/uploads/2022/09/cropped-WBN-squate-stripes-Copy-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.worldboxingnews.net/wp-content/uploads/2022/09/cropped-WBN-squate-stripes-Copy-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.worldboxingnews.net/wp-content/uploads/2022/09/cropped-WBN-squate-stripes-Copy-270x270.jpg" />
<script data-no-optimize='1' data-cfasync='false' id='cls-disable-ads-fe023b2'>var cls_disable_ads=function(t){"use strict";var e=function(t){var e=window.location.href;return t.some((function(t){return new RegExp(t,"i").test(e)}))},i=function(){function t(t){this.adthrive=t,this.all=!1,this.content=!1,this.recipe=!1,this.video=!1,this.locations=new Set,this.reasons=new Set,(this.urlHasEmail(window.location.href)||this.urlHasEmail(window.document.referrer))&&(this.all=!0,this.reasons.add("all_email"));try{this.checkCommandQueue(),null!==document.querySelector(".tag-novideo")&&(this.video=!0,this.locations.add("Video"),this.reasons.add("video_tag"))}catch(t){}}return t.prototype.checkCommandQueue=function(){var t=this;this.adthrive&&this.adthrive.cmd&&this.adthrive.cmd.forEach((function(e){var i=e.toString(),a=t.extractAPICall(i,"disableAds");a&&t.disableAllAds(t.extractPatterns(a));var n=t.extractAPICall(i,"disableContentAds");n&&t.disableContentAds(t.extractPatterns(n));var s=t.extractAPICall(i,"disablePlaylistPlayers");s&&t.disablePlaylistPlayers(t.extractPatterns(s))}))},t.prototype.extractPatterns=function(t){var e=t.match(/\'(.*?)\'/g);if(null!==e)return e.map((function(t){return t.replace(/'/g,"")}))},t.prototype.extractAPICall=function(t,e){var i=new RegExp(e+"\\((.*?)\\)","g"),a=t.match(i);return null!==a&&a[0]},t.prototype.disableAllAds=function(t){t&&!e(t)||(this.all=!0,this.reasons.add("all_page"))},t.prototype.disableContentAds=function(t){t&&!e(t)||(this.content=!0,this.recipe=!0,this.locations.add("Content"),this.locations.add("Recipe"),this.reasons.add("content_plugin"))},t.prototype.disablePlaylistPlayers=function(t){t&&!e(t)||(this.video=!0,this.locations.add("Video"),this.reasons.add("video_page"))},t.prototype.urlHasEmail=function(t){if(!t)return!1;return null!==/([A-Z0-9._%+-]+(@|%(25)*40)[A-Z0-9.-]+\.[A-Z]{2,})/i.exec(t)},t}(),a=window.adthriveCLS;return a&&(a.disableAds=new i(window.adthrive)),t.ClsDisableAds=i,Object.defineProperty(t,"__esModule",{value:!0}),t}({});
</script> <style type="text/css" id="wp-custom-css">
			.wp-caption.featured {
    position: relative;
    margin: 0;
}

.wp-caption.featured .wp-caption-text {
    position: absolute;
    left: 5px;
    bottom: 6px;
    padding: 2px 1px;
    color: #fff;
    font-weight: bold;
    font-size: 12px;
    font-style: italic;
	text-shadow: 2px 2px #000000;
}

.single-post .type-post,
.single-post .comments-area {
  margin-bottom: 0;
}

/* Remove sidebar from mobile devices - Neve Version - 18th of July 2022*/
@media (max-width: 992px){
    .blog-sidebar {
        display: none !important;
    }
}


		</style>



<script async src="https://www.googletagmanager.com/gtag/js?id=UA-17964668-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17964668-1');
</script>
<meta name="msvalidate.01" content="751805980777FF01F8200AE4389D0475" />
<meta name="yandex-verification" content="0e505eeef2444632" />
<link href="https://www.worldboxingnews.net/wp-content/uploads/omgf/omgf-stylesheet-136/omgf-stylesheet-136.css?ver=1658694605" rel="stylesheet">
</head>
<body class="post-template-default single single-post postid-99945 single-format-standard wp-custom-logo  nv-blog-grid nv-sidebar-right menu_sidebar_slide_left" id="neve_body">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div class="wrapper">
<header class="header">
 <a class="neve-skip-link show-on-focus" href="#content">
Skip to content </a>
<div id="header-grid" class="hfg_header site-header">
<div class="header--row header-top hide-on-mobile hide-on-tablet layout-full-contained header--row" data-row-id="top" data-show-on="desktop">
<div class="header--row-inner header-top-inner">
<div class="container">
<div class="row row--wrapper" data-section="hfg_header_layout_top">
<div class="hfg-slot left"><div class="builder-item desktop-left"><div class="item--inner builder-item--logo" data-section="title_tagline" data-item-id="logo">
<div class="site-logo">
<a class="brand" href="https://www.worldboxingnews.net/" title="WBN - World Boxing News" aria-label="WBN - World Boxing News"><picture class="neve-site-logo skip-lazy sp-no-webp" loading="lazy" data-variant="logo"><source srcset="https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site.webp 600w,https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site-300x60.webp 300w" sizes="(max-width: 600px) 100vw, 600px" type="image/webp"><source srcset="https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site.png 600w, https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site-300x60.png 300w" sizes="(max-width: 600px) 100vw, 600px" type="image/png"><img src="https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site.png" class="neve-site-logo skip-lazy sp-no-webp" loading="lazy" data-variant="logo" alt="World Boxing News logo { width: 600px; aspect-ratio: auto 600 / 120; height: 120px; }" height="120" width="600" srcset="https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site.png 600w, https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site-300x60.png 300w" sizes="(max-width: 600px) 100vw, 600px"></picture></a></div>
</div>
</div></div><div class="hfg-slot right"><div class="builder-item desktop-left"><div class="item--inner builder-item--social_icons" data-section="social_icons" data-item-id="social_icons">
<div class="component-wrap">
<ul class="nv-social-icons-list">
<li>
<a href="https://www.facebook.com/officialworldboxingnews" style="fill:#fff;background:#3b5998;" title="Facebook" aria-label="Facebook">
<svg width="0" height="0" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z" /></svg> </a>
</li>
<li>
<a href="https://twitter.com/worldboxingnews" style="fill:#fff;background:#1da1f2;" title="Twitter" aria-label="Twitter">
<svg width="0" height="0" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z" /></svg> </a>
</li>
<li>
<a href="https://www.instagram.com/worldboxingnews/" style="fill:#fff;background:#e1306c;" title="Instagram" aria-label="Instagram">
<svg width="0" height="0" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1152 896q0-106-75-181t-181-75-181 75-75 181 75 181 181 75 181-75 75-181zm138 0q0 164-115 279t-279 115-279-115-115-279 115-279 279-115 279 115 115 279zm108-410q0 38-27 65t-65 27-65-27-27-65 27-65 65-27 65 27 27 65zm-502-220q-7 0-76.5-.5t-105.5 0-96.5 3-103 10-71.5 18.5q-50 20-88 58t-58 88q-11 29-18.5 71.5t-10 103-3 96.5 0 105.5.5 76.5-.5 76.5 0 105.5 3 96.5 10 103 18.5 71.5q20 50 58 88t88 58q29 11 71.5 18.5t103 10 96.5 3 105.5 0 76.5-.5 76.5.5 105.5 0 96.5-3 103-10 71.5-18.5q50-20 88-58t58-88q11-29 18.5-71.5t10-103 3-96.5 0-105.5-.5-76.5.5-76.5 0-105.5-3-96.5-10-103-18.5-71.5q-20-50-58-88t-88-58q-29-11-71.5-18.5t-103-10-96.5-3-105.5 0-76.5.5zm768 630q0 229-5 317-10 208-124 322t-322 124q-88 5-317 5t-317-5q-208-10-322-124t-124-322q-5-88-5-317t5-317q10-208 124-322t322-124q88-5 317-5t317 5q208 10 322 124t124 322q5 88 5 317z" /></svg> </a>
</li>
<li>
<a href="https://www.youtube.com/user/WorldBoxingNews" style="fill:#fff;background:#cd201f;" title="Youtube" aria-label="Youtube">
<svg width="0" height="0" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M711 1128l484-250-484-253v503zm185-862q168 0 324.5 4.5t229.5 9.5l73 4q1 0 17 1.5t23 3 23.5 4.5 28.5 8 28 13 31 19.5 29 26.5q6 6 15.5 18.5t29 58.5 26.5 101q8 64 12.5 136.5t5.5 113.5v176q1 145-18 290-7 55-25 99.5t-32 61.5l-14 17q-14 15-29 26.5t-31 19-28 12.5-28.5 8-24 4.5-23 3-16.5 1.5q-251 19-627 19-207-2-359.5-6.5t-200.5-7.5l-49-4-36-4q-36-5-54.5-10t-51-21-56.5-41q-6-6-15.5-18.5t-29-58.5-26.5-101q-8-64-12.5-136.5t-5.5-113.5v-176q-1-145 18-290 7-55 25-99.5t32-61.5l14-17q14-15 29-26.5t31-19.5 28-13 28.5-8 23.5-4.5 23-3 17-1.5q251-18 627-18z" /></svg> </a>
</li>
<li>
<a href="https://www.tiktok.com/@worldboxingnews" style="fill:#fefefe;background:#000000;" title="Tik Tok" aria-label="Tik Tok">
<svg width="0" height="0" viewBox="0 0 512 512" xmlns="http://www.w3.org/2000/svg"><path d="M412.19,118.66a109.27,109.27,0,0,1-9.45-5.5,132.87,132.87,0,0,1-24.27-20.62c-18.1-20.71-24.86-41.72-27.35-56.43h.1C349.14,23.9,350,16,350.13,16H267.69V334.78c0,4.28,0,8.51-.18,12.69,0,.52-.05,1-.08,1.56,0,.23,0,.47-.05.71,0,.06,0,.12,0,.18a70,70,0,0,1-35.22,55.56,68.8,68.8,0,0,1-34.11,9c-38.41,0-69.54-31.32-69.54-70s31.13-70,69.54-70a68.9,68.9,0,0,1,21.41,3.39l.1-83.94a153.14,153.14,0,0,0-118,34.52,161.79,161.79,0,0,0-35.3,43.53c-3.48,6-16.61,30.11-18.2,69.24-1,22.21,5.67,45.22,8.85,54.73v.2c2,5.6,9.75,24.71,22.38,40.82A167.53,167.53,0,0,0,115,470.66v-.2l.2.2C155.11,497.78,199.36,496,199.36,496c7.66-.31,33.32,0,62.46-13.81,32.32-15.31,50.72-38.12,50.72-38.12a158.46,158.46,0,0,0,27.64-45.93c7.46-19.61,9.95-43.13,9.95-52.53V176.49c1,.6,14.32,9.41,14.32,9.41s19.19,12.3,49.13,20.31c21.48,5.7,50.42,6.9,50.42,6.9V131.27C453.86,132.37,433.27,129.17,412.19,118.66Z" /></svg> </a>
</li>
</ul>
</div>
</div>
</div></div> </div>
</div>
</div>
</div>
<nav class="header--row header-main hide-on-mobile hide-on-tablet layout-full-contained nv-navbar header--row" data-row-id="main" data-show-on="desktop">
<div class="header--row-inner header-main-inner">
<div class="container">
<div class="row row--wrapper" data-section="hfg_header_layout_main">
<div class="hfg-slot left"></div><div class="hfg-slot right"><div class="builder-item has-nav hfg-is-group has-primary-menu"><div class="item--inner builder-item--primary-menu has_menu" data-section="header_menu_primary" data-item-id="primary-menu">
<div class="nv-nav-wrap">
<div role="navigation" class="style-plain nav-menu-primary" aria-label="Primary Menu">
<ul id="nv-primary-navigation-main" class="primary-menu-ul nav-ul"><li id="menu-item-92437" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-92437"><a href="https://www.worldboxingnews.net/">Home</a></li>
<li id="menu-item-89945" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89945"><a target="_blank" rel="noopener" href="https://www.fixturecalendar.com/?sport=Boxing">Schedule</a></li>
<li id="menu-item-94747" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-94747"><a><span class="menu-item-title-wrap dd-title">Champions</span><div role="none" tabindex="-1" class="caret-wrap 3"><span class="caret"><svg aria-label="Dropdown" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path d="M207.029 381.476L12.686 187.132c-9.373-9.373-9.373-24.569 0-33.941l22.667-22.667c9.357-9.357 24.522-9.375 33.901-.04L224 284.505l154.745-154.021c9.379-9.335 24.544-9.317 33.901.04l22.667 22.667c9.373 9.373 9.373 24.569 0 33.941L240.971 381.476c-9.373 9.372-24.569 9.372-33.942 0z" /></svg></span></div></a>
<ul class="sub-menu">
<li id="menu-item-69395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69395"><a href="https://www.worldboxingnews.net/boxing-world-champions-wbc-ibf-wbo-wba/">Boxing World Champions</a></li>
<li id="menu-item-92713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-92713"><a href="https://www.worldboxingnews.net/2022/01/03/lineal-heavyweight-championship-history/">Lineal Heavyweights</a></li>
</ul>
</li>
<li id="menu-item-69392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69392"><a><span class="menu-item-title-wrap dd-title">Rankings</span><div role="none" tabindex="-1" class="caret-wrap 6"><span class="caret"><svg aria-label="Dropdown" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path d="M207.029 381.476L12.686 187.132c-9.373-9.373-9.373-24.569 0-33.941l22.667-22.667c9.357-9.357 24.522-9.375 33.901-.04L224 284.505l154.745-154.021c9.379-9.335 24.544-9.317 33.901.04l22.667 22.667c9.373 9.373 9.373 24.569 0 33.941L240.971 381.476c-9.373 9.372-24.569 9.372-33.942 0z" /></svg></span></div></a>
<ul class="sub-menu">
<li id="menu-item-94723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-94723"><a href="https://www.worldboxingnews.net/pound-for-pound-rankings-wbn-top-50/">Pound for Pound Top 50</a></li>
<li id="menu-item-94722" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-94722"><a href="https://www.worldboxingnews.net/2022/09/15/pound-for-pound-number-one-history/">Pound for Pound History 1970 &#8211;</a></li>
</ul>
</li>
<li id="menu-item-96327" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96327"><a href="https://www.worldboxingnews.net/category/scorecard-archives/">Scorecards</a></li>
<li id="menu-item-83800" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83800"><a href="https://www.worldboxingnews.net/2021/05/26/world-boxing-news-awards-2010-20/">Awards</a></li>
<li id="menu-item-92711" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-92711"><a href="https://www.worldboxingnews.net/boxing-news-wbn/">News</a></li>
</ul> </div>
</div>
</div>
<div class="item--inner builder-item--header_search_responsive" data-section="header_search_responsive" data-item-id="header_search_responsive">
<div class="nv-search-icon-component">
<div class="menu-item-nav-search minimal">
<a aria-label="Search" href="#" class="nv-icon nv-search">
<svg width="15" height="15" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" /></svg>
</a> <div class="nv-nav-search" aria-label="search">
<div class="form-wrap ">
<form role="search" method="get" class="search-form" action="https://www.worldboxingnews.net/">
<label>
<span class="screen-reader-text">Search for...</span>
</label>
<input type="search" class="search-field" aria-label="Search" placeholder="Search for..." value="" name="s" />
<button type="submit" class="search-submit" aria-label="Search">
<span class="nv-search-icon-wrap">
<span class="nv-icon nv-search">
<svg width="15" height="15" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" /></svg>
</span></span>
</button>
</form>
</div>
</div>
</div>
</div>
</div>
</div></div> </div>
</div>
</div>
</nav>
<nav class="header--row header-main hide-on-desktop layout-full-contained nv-navbar header--row" data-row-id="main" data-show-on="mobile">
<div class="header--row-inner header-main-inner">
<div class="container">
<div class="row row--wrapper" data-section="hfg_header_layout_main">
<div class="hfg-slot left"><div class="builder-item tablet-left mobile-left"><div class="item--inner builder-item--logo" data-section="title_tagline" data-item-id="logo">
<div class="site-logo">
<a class="brand" href="https://www.worldboxingnews.net/" title="WBN - World Boxing News" aria-label="WBN - World Boxing News"><picture class="neve-site-logo skip-lazy sp-no-webp" loading="lazy" data-variant="logo"><source srcset="https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site.webp 600w,https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site-300x60.webp 300w" sizes="(max-width: 600px) 100vw, 600px" type="image/webp"><source srcset="https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site.png 600w, https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site-300x60.png 300w" sizes="(max-width: 600px) 100vw, 600px" type="image/png"><img src="https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site.png" class="neve-site-logo skip-lazy sp-no-webp" loading="lazy" data-variant="logo" alt="World Boxing News logo { width: 600px; aspect-ratio: auto 600 / 120; height: 120px; }" height="120" width="600" srcset="https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site.png 600w, https://www.worldboxingnews.net/wp-content/uploads/2022/06/cropped-wbn-logo-new-site-300x60.png 300w" sizes="(max-width: 600px) 100vw, 600px"></picture></a></div>
</div>
</div></div><div class="hfg-slot right"><div class="builder-item tablet-left mobile-left hfg-is-group"><div class="item--inner builder-item--header_search_responsive" data-section="header_search_responsive" data-item-id="header_search_responsive">
<div class="nv-search-icon-component">
<div class="menu-item-nav-search minimal">
<a aria-label="Search" href="#" class="nv-icon nv-search">
<svg width="15" height="15" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" /></svg>
</a> <div class="nv-nav-search" aria-label="search">
<div class="form-wrap ">
<form role="search" method="get" class="search-form" action="https://www.worldboxingnews.net/">
<label>
<span class="screen-reader-text">Search for...</span>
</label>
<input type="search" class="search-field" aria-label="Search" placeholder="Search for..." value="" name="s" />
<button type="submit" class="search-submit" aria-label="Search">
<span class="nv-search-icon-wrap">
<span class="nv-icon nv-search">
<svg width="15" height="15" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" /></svg>
</span></span>
</button>
</form>
</div>
</div>
</div>
</div>
</div>
<div class="item--inner builder-item--nav-icon" data-section="header_menu_icon" data-item-id="nav-icon">
<div class="menu-mobile-toggle item-button navbar-toggle-wrapper">
<button type="button" class=" navbar-toggle" value="Navigation Menu" aria-label="Navigation Menu ">
<span class="bars">
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</span>
<span class="screen-reader-text">Navigation Menu</span>
</button>
</div> 
</div>
</div></div> </div>
</div>
</div>
</nav>
<div id="header-menu-sidebar" class="header-menu-sidebar menu-sidebar-panel slide_left" data-row-id="sidebar">
<div id="header-menu-sidebar-bg" class="header-menu-sidebar-bg">
<div class="close-sidebar-panel navbar-toggle-wrapper">
<button type="button" class="hamburger is-active  navbar-toggle active" value="Navigation Menu" aria-label="Navigation Menu ">
<span class="bars">
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</span>
<span class="screen-reader-text">
Navigation Menu </span>
</button>
</div>
<div id="header-menu-sidebar-inner" class="header-menu-sidebar-inner ">
<div class="builder-item has-nav"><div class="item--inner builder-item--primary-menu has_menu" data-section="header_menu_primary" data-item-id="primary-menu">
<div class="nv-nav-wrap">
<div role="navigation" class="style-plain nav-menu-primary" aria-label="Primary Menu">
<ul id="nv-primary-navigation-sidebar" class="primary-menu-ul nav-ul"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-92437"><a href="https://www.worldboxingnews.net/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89945"><a target="_blank" rel="noopener" href="https://www.fixturecalendar.com/?sport=Boxing">Schedule</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-94747"><div class="wrap"><a><span class="menu-item-title-wrap dd-title">Champions</span></a><button tabindex="0" type="button" class="caret-wrap navbar-toggle 3"><span class="caret"><svg aria-label="Dropdown" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path d="M207.029 381.476L12.686 187.132c-9.373-9.373-9.373-24.569 0-33.941l22.667-22.667c9.357-9.357 24.522-9.375 33.901-.04L224 284.505l154.745-154.021c9.379-9.335 24.544-9.317 33.901.04l22.667 22.667c9.373 9.373 9.373 24.569 0 33.941L240.971 381.476c-9.373 9.372-24.569 9.372-33.942 0z" /></svg></span></button></div>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69395"><a href="https://www.worldboxingnews.net/boxing-world-champions-wbc-ibf-wbo-wba/">Boxing World Champions</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-92713"><a href="https://www.worldboxingnews.net/2022/01/03/lineal-heavyweight-championship-history/">Lineal Heavyweights</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69392"><div class="wrap"><a><span class="menu-item-title-wrap dd-title">Rankings</span></a><button tabindex="0" type="button" class="caret-wrap navbar-toggle 6"><span class="caret"><svg aria-label="Dropdown" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path d="M207.029 381.476L12.686 187.132c-9.373-9.373-9.373-24.569 0-33.941l22.667-22.667c9.357-9.357 24.522-9.375 33.901-.04L224 284.505l154.745-154.021c9.379-9.335 24.544-9.317 33.901.04l22.667 22.667c9.373 9.373 9.373 24.569 0 33.941L240.971 381.476c-9.373 9.372-24.569 9.372-33.942 0z" /></svg></span></button></div>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-94723"><a href="https://www.worldboxingnews.net/pound-for-pound-rankings-wbn-top-50/">Pound for Pound Top 50</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-94722"><a href="https://www.worldboxingnews.net/2022/09/15/pound-for-pound-number-one-history/">Pound for Pound History 1970 &#8211;</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96327"><a href="https://www.worldboxingnews.net/category/scorecard-archives/">Scorecards</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83800"><a href="https://www.worldboxingnews.net/2021/05/26/world-boxing-news-awards-2010-20/">Awards</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-92711"><a href="https://www.worldboxingnews.net/boxing-news-wbn/">News</a></li>
</ul> </div>
</div>
</div>
</div> </div>
</div>
</div>
<div class="header-menu-sidebar-overlay hfg-ov"></div>
</div>
<div id="page-header-grid" class="hfg_page_header page-header">
</div>
</header>
<style>.header-menu-sidebar .nav-ul li .wrap { position:relative; padding: 15px 0; display: flex; align-items: center; }.header-menu-sidebar .nav-ul li .wrap a { flex-grow: 1; }.header-menu-sidebar .nav-ul li .wrap a .dd-title { width: var(--wrapdropdownwidth); }.header-menu-sidebar .nav-ul li .wrap button { border: 0; z-index: 1; background: 0; }</style>
<main id="content" class="neve-main">
<div class="container single-post-container">
<div class="row">
<article id="post-99945" class="nv-single-post-wrap col post-99945 post type-post status-publish format-standard has-post-thumbnail hentry category-featured tag-british-boxing-board-of-control tag-conor-benn tag-ukad tag-vada tag-wbc">
<div class="entry-header"><div class="nv-title-meta-wrap"><small class="nv--yoast-breadcrumb neve-breadcrumbs-wrapper"><span><span><a href="https://www.worldboxingnews.net/">Home</a> » <span class="breadcrumb_last" aria-current="page">Conor Benn suspension not guaranteed, Doctor urged to speak</span></span></span></small><h1 class="title entry-title">Conor Benn suspension not guaranteed, Doctor urged to speak</h1><ul class="nv-meta-list"><li class="meta author vcard "><span class="author-name fn">by <a href="https://www.worldboxingnews.net/author/phildjay/" title="Posts by Phil Jay" rel="author">Phil Jay</a></span></li><li class="meta date posted-on "><time class="entry-date published" datetime="2022-10-29T11:07:09+01:00" content="2022-10-29">29th October 2022</time><time class="updated" datetime="2022-10-29T11:07:28+01:00">29th October 2022</time></li><li class="meta category "><a href="https://www.worldboxingnews.net/category/featured/" rel="category tag">Featured</a></li><li class="meta reading-time ">4 min read</li></ul></div></div><div class="nv-thumb-wrap"><figure class="wp-caption featured"><picture class="skip-lazy wp-post-image sp-no-webp"><source srcset="https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1.webp 1200w,https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1-300x169.webp 300w,https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1-768x432.webp 768w" sizes="(max-width: 1200px) 100vw, 1200px" type="image/webp"><source srcset="https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1.jpg 1200w, https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1-300x169.jpg 300w, https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1-768x432.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" type="image/jpeg"><img src="https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1-1200x675.jpg" class="skip-lazy wp-post-image sp-no-webp" alt="Conor Benn doctor" height="675" width="1200" srcset="https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1.jpg 1200w, https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1-300x169.jpg 300w, https://www.worldboxingnews.net/wp-content/uploads/2022/10/Benn-doctor-min-1-768x432.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px"></picture><figcaption class="wp-caption-text">Mark Robinson</figcaption></figure></div><div class="nv-content-wrap entry-content"><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.worldboxingnews.net/2022/10/29/conor-benn-suspension-doctor-speak/" data-a2a-title="Conor Benn suspension not guaranteed, Doctor urged to speak"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.worldboxingnews.net%2F2022%2F10%2F29%2Fconor-benn-suspension-doctor-speak%2F&amp;linkname=Conor%20Benn%20suspension%20not%20guaranteed%2C%20Doctor%20urged%20to%20speak" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.worldboxingnews.net%2F2022%2F10%2F29%2Fconor-benn-suspension-doctor-speak%2F&amp;linkname=Conor%20Benn%20suspension%20not%20guaranteed%2C%20Doctor%20urged%20to%20speak" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=https%3A%2F%2Fwww.worldboxingnews.net%2F2022%2F10%2F29%2Fconor-benn-suspension-doctor-speak%2F&amp;linkname=Conor%20Benn%20suspension%20not%20guaranteed%2C%20Doctor%20urged%20to%20speak" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fwww.worldboxingnews.net%2F2022%2F10%2F29%2Fconor-benn-suspension-doctor-speak%2F&amp;linkname=Conor%20Benn%20suspension%20not%20guaranteed%2C%20Doctor%20urged%20to%20speak" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.worldboxingnews.net%2F2022%2F10%2F29%2Fconor-benn-suspension-doctor-speak%2F&amp;linkname=Conor%20Benn%20suspension%20not%20guaranteed%2C%20Doctor%20urged%20to%20speak" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.worldboxingnews.net%2F2022%2F10%2F29%2Fconor-benn-suspension-doctor-speak%2F&amp;linkname=Conor%20Benn%20suspension%20not%20guaranteed%2C%20Doctor%20urged%20to%20speak" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><div class='code-block code-block-13' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div class="clever-core-ads"></div></div>
<p><strong>Due to the relinquishing of his British Boxing license, Conor Benn could escape suspension for two failed drug tests, World Boxing News understands.</strong></p>
<p>The tests, one dating back three months, as father Nigel Benn stated before correcting himself to &#8220;three weeks,&#8221; were ratified with trace amounts of the same drug.</p>
<p>Benn gave up his UK paperwork last week and had since vowed never to fight under the jurisdiction of the BBBofC.</p>
<h2>Will Conor Benn get a ban for failed drug tests?</h2>
<p>This outcome means any future ban would be obsolete, and Benn is free to go overseas to get his sanction to box. Furthermore, UKAD &#8211; the body that usually hands out punishments, are powerless in this instance as &#8220;The Destroyer&#8221; didn&#8217;t fail any of their tests.</p>
<p>WBN determined that Benn could escape a ban. The recommendation from VADA would only be actionable by the World Boxing Council at this point.</p>
<p>Even if the WBC does give the British welterweight a ban, which is certainly not set in stone, Benn would still be able to apply his trade outside the organization&#8217;s scope.</p>
<p>It would only be UKAD that could fully put Benn out of action. But even then, there are options to get around that possible happening.</p>
<p>Regarding VADA &#8211; the body that uncovered the adverse findings in two separate samples &#8211; they do not handle the adjudication of results.</p>
<h2>Drug test results</h2>
<p>Adjudication is left to the commissions and sanctioning bodies. VADA always gives the results of their tests to the athlete, promoters, commission, sanctioning bodies involved, and the ABC.</p>
<p>The Chris Eubank Jr. fight had no major sanctioning bodies involved. However, Benn was ranked by the WBC and engaged in their Clean Boxing Program.</p>
<p>They are well within their rights to suspend Benn from the ratings for a certain period. Also, to make recommendations elsewhere &#8211; for instance &#8211; to UKAD.</p>
<p>We know that the World Boxing Council President Mauricio Sulaiman was informed of Benn&#8217;s test failures, as was promoter Eddie Hearn.</p>
<p>The Association of Boxing Commissions would also get the relevant information. So they could act as far as Benn fighting in the United States.</p>
<p>British Boxing Board of Control chief Robert Smith is known to be delving deeper into the situation. As of right now, he is holding Benn to account publicly.</p>
<p>Their stance pushed Benn fully out of favor with the public. He then accused the Board of bias and &#8220;having it in for him.&#8221;</p>
<h3>Dr. Usman Sajjad</h3>
<p>But what about the doctor who worked in camp with Benn? &#8211; Dr. Usman Sajjad reportedly came under <a href="https://www.worldboxingnews.net/2019/11/11/amir-khan-errol-spence-crash-earnings/">investigation</a> early in October, according to UK media reports.</p>
<p>So far, no information is forthcoming on Sajjad&#8217;s role. He did post several times on social media regarding working with Benn.</p>
<p>In another twist, he made shocking statements about boxers doping in a podcast interview.</p>
<p>He also removed his website and social accounts on the day Benn&#8217;s test failures became public. It&#8217;s another potentially damning action.</p>
<p>Fans want &#8220;Dr. Uz&#8221; to explain his role in Benn&#8217;s team. To divulge what knowledge, if any, he had about what the fighter was ingesting.</p>
<p>At the moment, it&#8217;s hard to see who can punish Benn. Only the boxer is stating he won&#8217;t fight until he clears his name.</p>
<p>Benn saw a catchweight fight with middleweight Eubank Jr. called off at the last minute due to the Board removing their backing.</p>
<p>Without that move, the event at the O2 Arena in London on Saturday, October 8, could have gone ahead without problems.</p>
<p>Also, the failed test got revealed through an unnamed whistleblower. Again, without this, the fight could have happened.</p>
<p>It&#8217;s no secret that Hearn and Benn could have sought a license outside of the UK to ensure the Pay Per View bout took place.</p>
<h3>Conor Benn is trying to clear his name</h3>
<p>Hearn decided against the move. Benn is now intent on trying to clear his name.</p>
<p>It must be noted that a significant percentage of the British public is skeptical at this point. That scenario becomes clear if you look at the sheer extent of social trolling against Benn.</p>
<p>He faces a tough fight. But getting in the ring again could prove a lot more straightforward unless UKAD or the WBC acts.</p>
<p>A suspension doesn&#8217;t look to be on the cards from either of those with the ultimate power to banish the Londoner.</p>
<p><strong><em>The views expressed in this article are the opinions of Phil Jay.</em></strong></p>
<p><em><strong>WBN Editor Phil Jay has over ten years of boxing news experience. Follow WBN on Facebook </strong></em><a href="https://www.facebook.com/officialworldboxingnews"><em>@officialworldboxingnews</em></a>,<em><strong> Instagram, and Twitter @</strong></em><a href="https://twitter.com/WorldBoxingNews"><em>worldboxingnews</em></a><em><strong>.</strong></em></p>
</div><div class="nv-tags-list"><span>Tags:</span><a href=https://www.worldboxingnews.net/tag/british-boxing-board-of-control/ title="British Boxing Board of Control" class=british-boxing-board-of-control rel="tag">British Boxing Board of Control</a><a href=https://www.worldboxingnews.net/tag/conor-benn/ title="Conor Benn" class=conor-benn rel="tag">Conor Benn</a><a href=https://www.worldboxingnews.net/tag/ukad/ title="UKAD" class=ukad rel="tag">UKAD</a><a href=https://www.worldboxingnews.net/tag/vada/ title="VADA" class=vada rel="tag">VADA</a><a href=https://www.worldboxingnews.net/tag/wbc/ title="WBC" class=wbc rel="tag">WBC</a> </div> <div class='code-block code-block-15' style='padding-top: 30px; padding-bottom: 0px; padding-left: 0px;'>

<div id="M1769ScriptRootC1283988"></div>
<script src="https://jsc.mgid.com/w/o/worldboxingnews.net.1283988.js" async></script>

</div>
</article>
<div class="nv-sidebar-wrap col-sm-12 nv-right blog-sidebar ">
<aside id="secondary" role="complementary">
<div id="block-26" class="widget widget_block">
<div style="height:10px" aria-hidden="true" class="wp-block-spacer"></div>
</div><div id="custom_html-15" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="http://www.newsnow.co.uk/h/Sport/Boxing" target="_blank" rel="noopener"><picture style="" class="img-responsive sp-no-webp"><source srcset="/wp-content/uploads/newsnow_f_ab.webp" type="image/webp"><source srcset="/wp-content/uploads/newsnow_f_ab.gif" type="image/gif"><img src="/wp-content/uploads/newsnow_f_ab.gif" style="min-height: 50px" class="img-responsive sp-no-webp" alt="news now logo" height="50" width="160" srcset="/wp-content/uploads/newsnow_f_ab.gif"></picture></a> </div></div><div id="block-29" class="widget widget_block"><div class="wp-widget-group__inner-blocks"><ul class="wp-block-latest-posts__list wp-block-latest-posts"><li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/29/conor-benn-suspension-doctor-speak/">Conor Benn suspension not guaranteed, Doctor urged to speak</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/28/deontay-wilder-harold-sconiers-ko-video/">Deontay Wilder KO&#8217;d by Harry Sconiers video evidence disappears</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/28/oleksandr-usyk-wins-wbo-fighter-of-the-year/">Oleksandr Usyk wins WBO Fighter of the Year</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/28/vasiliy-lomachenko-aims-to-show-his-class-against-jamaine-ortiz/">Vasiliy Lomachenko aims to show his class against Jamaine Ortiz</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/28/jojo-diaz-and-william-zepeda-ready-for-war/">JoJo Diaz and William Zepeda ready for war</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/28/jake-paul-anderson-silva-team-up-to-fight-dana-white-and-the-ufc/">Jake Paul, Anderson Silva team up to fight Dana White and the UFC</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/28/jake-paul-wbc-president-muhammad-ali/">Our &#8216;Muhammad Ali,&#8217; Jake Paul gets ex-champ handicap fight offer</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/28/anthony-joshua-mentally-scarred-carl-froch/">&#8216;Anthony Joshua got beat up, he&#8217;s mentally scarred&#8217; &#8211; Carl Froch</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/28/conor-benn-drug-test-defense-polarizing/">Conor Benn launches drug test defense to polarizing response</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/27/gilbero-ramirez-bivol-win-wbn-exclusive/">Exclusive: Gilberto Ramirez aims for 45-0 with Dmitry Bivol win</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/27/boxing-news-golovkin-options-bam-rodriguez-wbo/">Boxing News: Golovkin has four options, Bam Rodriguez, WBO</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/27/deontay-wilder-dustin-nichols-2010/">Deontay Wilder &#8216;dropped&#8217; first by opponent weighing 398 pounds</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/27/matchroom-boxing-swoop-for-two-team-gb-boxing-members/">Matchroom Boxing swoop for two Team GB Boxing members</a></li>
<li><a class="wp-block-latest-posts__post-title" href="https://www.worldboxingnews.net/2022/10/27/david-morrell-jr-aidos-yerbossynuly-discuss-nov-5-collision/">David Morrell Jr., Aidos Yerbossynuly discuss Nov 5 collision</a></li>
</ul></div></div>
</aside>
</div>
</div>
</div>
</main>
<a tabindex="0" id="scroll-to-top" class="scroll-to-top scroll-to-top-right icon" aria-label="Scroll to Top"><svg class="scroll-to-top-icon" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" width="15" height="15" viewBox="0 0 15 15"><rect width="15" height="15" fill="none" /><path fill="currentColor" d="M14.71,10.3l-6.48-7a1,1,0,0,0-1.46,0l-6.48,7A1,1,0,0,0,1,12H14a1,1,0,0,0,.73-1.68Z" /></svg></a><footer class="site-footer nv-cv-m nv-cv-d" id="site-footer">
<div class="hfg_footer">
<div class="footer--row footer-top layout-full-contained" id="cb-row--footer-top" data-row-id="top" data-show-on="desktop">
<div class="footer--row-inner footer-top-inner footer-content-wrap">
<div class="container">
<div class="hfg-grid nv-footer-content hfg-grid-top row--wrapper row " data-section="hfg_footer_layout_top">
<div class="hfg-slot left"><div class="builder-item desktop-left tablet-center mobile-center"><div class="item--inner builder-item--widget-area-4" data-section="neve_sidebar-widgets-widget-area-4" data-item-id="widget-area-4">
<div class="widget-area">
</div>
</div>
</div></div> </div>
</div>
</div>
</div>
<div class="footer--row footer-main layout-full-contained" id="cb-row--footer-main" data-row-id="main" data-show-on="desktop">
<div class="footer--row-inner footer-main-inner footer-content-wrap">
<div class="container">
<div class="hfg-grid nv-footer-content hfg-grid-main row--wrapper row " data-section="hfg_footer_layout_main">
<div class="hfg-slot left"><div class="builder-item desktop-left tablet-left mobile-left"><div class="item--inner builder-item--footer-one-widgets" data-section="neve_sidebar-widgets-footer-one-widgets" data-item-id="footer-one-widgets">
<div class="widget-area">
<div id="block-2" class="widget widget_block widget_media_image">
<figure class="wp-block-image size-full"><a href="https://www.worldboxingnews.net/"><picture loading="lazy" class="wp-image-92440 sp-no-webp"><source srcset="https://www.worldboxingnews.net/wp-content/uploads/2022/06/logo-2.webp 302w,https://www.worldboxingnews.net/wp-content/uploads/2022/06/logo-2-300x62.webp 300w" sizes="(max-width: 302px) 100vw, 302px" type="image/webp"><source srcset="https://www.worldboxingnews.net/wp-content/uploads/2022/06/logo-2.png 302w, https://www.worldboxingnews.net/wp-content/uploads/2022/06/logo-2-300x62.png 300w" sizes="(max-width: 302px) 100vw, 302px" type="image/png"><img src="https://www.worldboxingnews.net/wp-content/uploads/2022/06/logo-2.png" loading="lazy" class="wp-image-92440 sp-no-webp" alt="" height="62" width="302" srcset="https://www.worldboxingnews.net/wp-content/uploads/2022/06/logo-2.png 302w, https://www.worldboxingnews.net/wp-content/uploads/2022/06/logo-2-300x62.png 300w" sizes="(max-width: 302px) 100vw, 302px"></picture></a></figure>
</div><div id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-footermenu-container"><ul id="menu-footermenu" class="menu"><li id="menu-item-95685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-95685"><a href="https://www.worldboxingnews.net/about-world-boxing-news-information/">About World Boxing News</a></li>
<li id="menu-item-70513" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70513"><a href="https://www.worldboxingnews.net/contact-world-boxing-news/">Contact World Boxing News</a></li>
<li id="menu-item-92726" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-92726"><a href="https://www.worldboxingnews.net/privacy-policy/">Privacy Policy</a></li>
</ul></div></div> </div>
</div>
</div></div><div class="hfg-slot c-left"></div><div class="hfg-slot center"></div>  </div>
</div>
</div>
</div>
<div class="footer--row footer-bottom layout-full-contained" id="cb-row--footer-bottom" data-row-id="bottom" data-show-on="desktop">
<div class="footer--row-inner footer-bottom-inner footer-content-wrap">
<div class="container">
<div class="hfg-grid nv-footer-content hfg-grid-bottom row--wrapper row " data-section="hfg_footer_layout_bottom">
<div class="hfg-slot left"><div class="builder-item desktop-left tablet-left mobile-left"><div class="item--inner builder-item--footer_copyright" data-section="footer_copyright" data-item-id="footer_copyright">
<div class="component-wrap">
<div>
<p>© World Boxing News 2022</p> </div>
</div>
</div>
</div></div> </div>
</div>
</div>
</div>
</div>
</footer>
</div>
<script data-no-optimize='1' data-cfasync='false' id='cls-insertion-fe023b2'>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</script>
